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Dedicated to … 
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Introduction 

 
• Co-founded Integra Solutions in 1993 

• Used BusinessObjects since 1992  
(Version 2.2) 

• Wrote the first BusinessObjects training  
manuals 

• Over 75 Fortune 1000 customers before  
company was sold in 2007 

• Presented at every national conference 
• Founded Solid Ground Technologies in 2009 

• Different company – same principles 
• Specialize in BusinessObjects  

consulting and training 

Alan Mayer 
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 Semantic layer that is created between data and the user 

 Expressed in business terms that users understand 

 Tables and joins are predefined 

A Universe? 

Universes Database Schema 

Database Query 
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 Universes contain 

 A connection to the data  

 A structural representation of that data 

 Business terms based on that structure 

A Simple Definition 

Structure Business  

terms 
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 Two types can be built based on version 

 .UNV 

 Legacy universes created in any current version (XI 3.1, BI 4.x) 

 To make things simpler, we’ll restrict .UNV to just XI 3.1 

 .UNX 

 New for BI 4.x installations 

 Which should you build? 

 Depends on your environment 

 Certain new features only available in .UNX 

 Multiple connections 

 More data sources 

 

Two Types of Universes 
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Another Way of Looking at it … 

.unv 

= .unv 

.blx 

.dfx 

.cnx or .cns 
+ 

+ 

= .unx 
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 Show how to build universes regardless of version 

 Many basic concepts are the same 

 Version-specific features will be pointed out 

 Look for these symbols 

 

 

 

 

 

 We’ll develop BOTH types of universes in this presentation! 

 

 

Our Mission 

3.1 

4.x 

.unv 

.unx 
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 Create a project  

 Add a data connection 

 Define the structure by inserting tables and joins 

 Resolve logical inconsistencies 

 Create classes and objects  

 Publish / export the final result 

 

 

Our Instruction Manual 

4.x 
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 Showing how universes are developed in 3.1 and 4.x is ambitious 

 Especially in less than an hour 

 Not much time for these topics: 

 Detailed connection and parameter selections 

 Performance tuning 

 Federation 

 Complex object and join creation 

 Hierarchies / Navigation paths 

 Aggregate navigation 

 Security rules 

 

 

 

 

Beyond Our Scope 
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 .UNV legacy universes can be created in either version 

 Universe Design tool in BI 4.x  

 Designer tool in XI 3.1 

 Very little difference between these two tools 

 

 Use the Information Design Tool (IDT) for .UNX  

 

 Best way to proceed: 

 Decide on which version (XI 3.1, BI 4.0) 

 Decide on which universe type to create (.UNV, .UNX) 

 Follow the slides for your choices 

 

 

Use the Right Tool 
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 Must log into the Universe Designer as the first step 

 No login necessary for IDT (.UNX)  

 

Logging in 3.1 

 
It is possible to 
bypass the login by 
setting Authentication 
to Standalone. You 
must have logged in 
at least once prior to 
trying. 
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 Developers must create a project to get started 

 File > New > Project 

 Projects contain: 

 Connections 

 Data Foundation layer (structure) 

 Business layer (business terms)  

 

Creating a Project  4.x 
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 Developers can create a new universe to get started 

 File > New 

Creating a Universe 3.1 
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 While in a project, create a new connection 

 File > New > Relational Connection or OLAP Connection 

 Relational Connection chosen below 

Creating Project Connections 4.x 

 
Connections to Excel 
and text files also 
available here. 
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 Additional connection choices 

 

Creating Project Connections, cont’d 4.x 

Relational OLAP 
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 Add login information to reach that data source 

 Relational example 

 User / password optional for MS Access, Excel, flat files 

 Additional details go beyond the scope of this talk  

Creating Project Connections, cont’d 4.x 
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 The initial connection is “local” (.cnx) 

 Cannot be access by anyone but yourself 

 Must be published for Webi-based universes 

 Right click on connection > Publish Connection to Repository  

Publishing the Connection 4.x 

 
What if a connection 
isn’t published? 
 
Data foundations 
could still use a local 
connection, BUT … 
 
Universes could not 
be published based 
on that connection 
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 The published connection can be stored in a folder 

 Select a folder and click Finish 

 Shortcut for the published connection is created (.cns) 

 This shortcut can be used in Data Foundations 

Publishing the Connection, cont’d 4.x 
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 Many connections can be created using the Universe Designer 

 Only one of these may be used per universe 

 Options may vary based on version (3.1 vs. 4.x) 

Creating a Single .UNV Connection 3.1 
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 The connection should be secured for Enterprise use 

 Meaning … other people have access to the connection 

 A few differences from BI 4.x connections 

 No connection folder 

 Can secure at creation time 

 Some of the data sources may not be available 

Creating a Single .UNV Connection, cont’d 3.1 

Connections must be 
secured before 
publishing the 
universe. This allows 
other Enterprise users 
to use it 
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Demonstration 3.1 4.x 
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 Once a connection is created, structure can be defined 

 In IDT, this is done by creating a Data Foundation layer (.dfx) 

 File > New > Data foundation 

Creating a Data Foundation 4.x 
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 Choose between single or multi-source 

 Some data sources require the multi-source option 

 This will involve federation techniques – beyond our scope 

Creating a Data Foundation, cont’d 4.x 
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 Choose the secured connection 

Creating a Data Foundation, cont’d 4.x 
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 Select the Insert menu drop-down 

 Select Insert Tables … 

 Select the club datasource and choose one or more tables 

 

Adding Tables 4.x 
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 Arrange the tables in the order to be joined 

 

Adding Tables, cont’d 4.x 
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 No concept of a data foundation 

 The structure is part of the universe once created 

 Initial Structure Pane window will be blank 

 

Adding Structure 3.1 

Structure Terms 
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 Use the Table Browser  

 Open the club data source 

 Select the tables needed then click Insert 

 Arrange the tables in the order to be connected 

Adding Tables 3.1 
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Demonstration 3.1 4.x 
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Joins 

 Relationships between tables can now be defined 

 Known as joins, these relationships can take many forms 

 Inner join 

 Outer join 

 Theta join 

 Recursive join 

 Self-restricting join 

 Shortcut join 

 The next few slides will explain each join type 

 

 

3.1 4.x 
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Inner Joins 

 Also known as equi-joins or normal joins 

 Usually take the the following form 

 Single join:  Primary Key (PK) = Foreign Key (FK) 

 Compound Join:  PK1 = FK1 and PK2 = FK2 and … 

 

 

City.city_id=Customer.city_id 

PK 

FK 

3.1 4.x 
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Outer Joins 

 Forces all rows from one table to be considered even if no 
matching row exists in second table 

 For example: “Return all customers and orders if they exist” 

 Syntax varies based on database 

 Outer joins CASCADE!  

 

3.1 4.x 
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Theta Joins 

 Relates two tables using relationships other than equality 

Customer.age  
BETWEEN  
Age_group.age_min and  
Age_group.age_max 

3.1 4.x 
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Recursive Joins 

 A row is related to other row(s) within the same table 

 Example: A sponsor may be stored in the same table as their 
 referrals 

Customer.sponsor_id = Customer.cust_id 

3.1 4.x 
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Self-Restricting Joins  

 A condition that should ALWAYS be applied against a table 

 A universal condition rather than a join 

 One way to force BusinessObjects to always add the condition to any 
SQL statement that references that table 

Country.country_id = 1 

3.1 4.x 
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Shortcut Joins  

 Provides a shortcut or alternative path between tables 

 Example: The Customer table may contain an extra column that 
 allows a direct join to Country 

Shortcut Join 

Join Editor 

3.1 4.x 



Copyri

ght © 

2004 

Join Cardinality  

 Join cardinalities MUST be defined 

 Cardinality determines the number of rows related to a current row 

 They help resolve logical problems later 

1:1 
A salesperson has 1 customer; 
A customer has 1 salesperson 

1:Many 
A salesperson has 1 or more customers; 
A customer has one salesperson 

A salesperson has 1 or more customers; 
A customer has 1 or more salespersons 

Many: 

Many 

3.1 4.x 
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Setting Cardinalities  

 Cardinalities can be established two different ways 

 Automatic Detection (not as good) 

 Manually via Join Editor (better) 

 

Automatic 

Manual 

3.1 4.x 
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Adding Joins  

 Several methods 

 Trace the join from one table to another 

 Click and drag from one column to another 

 

 

 

 Use the Join Editor 

 Insert Menu > Insert Join  

 Detect joins 

 Tools > Automated Detection > Detect Joins 

 From Data Foundation: Detect > Detect Joins 

 

 

 

4.x 3.1 

 
Detecting joins is not 
a preferred strategy. 
Additional joins may 
be added that are 
technically possible 
but not realistic 
 
 

3.1 

4.x 
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Demonstration 3.1 4.x 
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Loops  

 A loop is created when two or more paths 
exist between tables 

 An employee can take a business trip to a country  

 An employee is born in a country 

 
Employee 

Trips 

Countries 

 

Employees 

 

Trips 

 

 
Another definition:  
Loops represent 
“pools of water” that 
cannot escape 
 
 

4.x 3.1 
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Loops, cont’d  

 Detecting Loops 

 Tools > Automated Detection > Detect Loops 

 Aliases and Contexts > Visualize Loops 

 

3.1 

4.x 

4.x 3.1 

 
Why are loops bad? 
 
SQL cannot be created 
because there is more than 
one path between tables 
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Loops, cont’d  

 Caution when using Detect tools …. 

 Join cardinalities must be set!  

 Else Detection may offer the wrong advice 

 Always review the solutions offered 

 

4.x 3.1 
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Chasm Traps  

 Look for logical traps 

 The chasm trap is a common one 

 Usually the result of a many to one,  
one to many relationship 

 Chasms cannot be crossed 

 Took a trip to England … 

 … means you were born there? 

 

 

 

 

 

 

 
1 1 

N N 

CHASM 

Trips Employees 

Countries 

 
Chasms are often created 
when joining to lookup 
tables. 
 

4.x 3.1 
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Chasm Traps, cont’d  

 Identfying chasms 

 In the following structure, Country is a chasm trap 

 
Setting cardinalities is important! 
It helps identify traps like this one 
 

4.x 3.1 
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Aliases  

 Aliases can resolve chasm traps 

 Known as table aliases when writing SQL statements 

 Used by BusinessObjects to logically separate the trap 
into pieces 

 

SELECT a.country, 

 b.country 

FROM  country a, 

 country b 

WHERE … 

Table aliases 

4.x 3.1 



Aliases, cont’d  

 Countries would be replaced by one (or two) aliases 

 Create an alias for each path 

 One alias is sufficient 

 Two aliases makes the diagram more readable 

 

Employee 

Trips 

Countries 

 

Destination_Countries 

(Countries) 

Nationality 

(Countries) 

Trips 

 

Employees 

 

 
The base table Countries must 
still remain in the Structure pane! 
 

4.x 3.1 



 Generic lookup tables can be resolved using aliases 
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Self-Restricting Join 

Sal_Lookups.type = ‘SAL’ 

Aliases  

Type Code Description 

SAL 001 Base Salary 

SAL 002 Overtime 

SAL 003 Company Car 

ABS 001 Holiday 

ABS 002 Sick 

ABS 003 Sick of Job 

Lookups 
Lookups 

 

Abs_Lookups 

(Lookups) 

Sal_Lookups 

(Lookups) 

Before: 

After: 
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Aliases  

 Recursive relationships can also be resolved 

 The depth of those relationships should be known 

Emp_ID Name Manager_ID 

1 Mayer 5 

5 Smith 23 

23 Betten 42 

42 Byrd 

Employees 

Employees 

 

Employees 

 

Managers 

(Employees) 

Before: 

After: 

Employees.manager_id = Managers.emp_id 

 
NOTE:  
There are better ways of 
resolving recursive relationships 
using database techniques 
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Aliases, cont’d  

 Every loop can be resolved with aliases 

 There are drawbacks to using aliases 

 More business terms (objects) will be added  

 Those additional terms may confuse some users 

 Aliases also CASCADE 

Problem #1 Problem #2 

4.x 3.1 
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Aliases  

 Adding aliases 

 Insert menu > Alias 

 Right-click on a table and choose Alias or Insert Alias 

 Aliases can also be detected 

 Tools menu > Automated Detection > Detect Aliases… 

 Data Foundation > Aliases and Contexts > Detect Contexts… 

 Looks for possible chasm traps for you 

 May not be a good idea based on previous drawbacks 

4.x 3.1 

3.1 

4.x 
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Demonstration 3.1 4.x 
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Contexts  

 Contexts can also resolve loops 

 A context represents one path or set of joins between tables 

Employees 

 

Trips 

 

Context #1: Trips 

Context #2: Nationality 

Employees.emp_id = Employee_Trips.emp_id 

Employee_Trips.trip_id = Trips.trip_id 

Trips.country_id = Countries.country_id 

Trips 

Employees.country_id = Countries.country_id Nationality 

Employee 

Trips 

Countries 

 

3.1 4.x 
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Contexts, cont’d  

 Contexts resolve the loop at runtime rather than in the Designer 

 This means that a context-based solution still has loops! 

 The user may be asked to choose between the contexts 

 BusinessObjects will try to infer which context to use 

 If it can’t figure it out, the user usually chooses a context 

 Once a context is chosen, all other joins “disappear” 

 Only joins listed in the context will be used to build the final SQL 
program 

 Using contexts does not force additional objects to be created 

3.1 4.x 

3.1 
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Contexts, cont’d  

 Adding contexts 

 Data Foundation > Aliases and Contexts > Add Context 

 Joins can be Included, Excluded, or Neutral 

 Include joins from one side of the loop 

 Exclude joins from the other side 

 All others will remain neutral (added by default) 

4.x 
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Contexts, cont’d  

 Adding contexts 

 Insert menu > Context… 

 Name the context and add a description 

 Choose the joins that will belong 

 WARNING! 

 All joins must be added that make business sense 

3.1 

 
New joins that are added 
after the context is created 
must be added to at least 
one context …. 
 
… else it will never be 
used! 
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Contexts, cont’d  

 Contexts can be detected 

 Tools menu > Automated Detection > Detect Contexts 

 Data Foundation > Aliases and Contexts > Detect Contexts 

 Use these options carefully 

 Don’t accept the proposed contexts blindly 

 Use them as an “assist” to create your own contexts 

3.1 4.x 

3.1 

4.x 
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Demonstration 3.1 4.x 
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Starting the User Interface  

 Classes and objects can now be created 

 Objects reveal portions of the database schema to your users 

 Act as “business terms” used to build queries 

 Automatically created for multi-dimensional data sources 

 Classes organizes those business terms 

 Known as folders in BI 4.x 

 Should make sense to the ultimate users 

 Organizing objects by table rarely make sense 

3.1 4.x 
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Starting the User Interface, cont’d  

 In IDT, this is done by creating a Business layer (.blx) 

 File > New > Business Layer 

 

4.x 
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Starting the User Interface, cont’d  

 In Universe Designer, use the Universe window 

 Informally known as the Classes and Objects pane 

 

3.1 
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Creating Classes  / Folders  

 Classes are like directories or folders for objects 

 Can be nested (sub-classes are fine) 

 Use any of these methods to create a class 

 Right-click on the Universe window and choose Class 

 Insert menu > Class… or Subclass… 

 Business Layer > Business Layer pane > New > Folder 

 

3.1 

4.x 

3.1 

3.1 4.x 

Always add descriptions to 
all new classes. This will 
make the universe easier 
to navigate for new users. 
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Object Definition  

 Objects are business terms used to create queries 

 They are SQL expressions when building a universe 

 … except for OLAP / multi-dimensional sources 

 50 – 75% of objects are usually just a table column 

 The remainder are calculations or expressions 

3.1 4.x 

SELECT <SQL expression 1>, 

 <SQL expression 2> 

FROM … 

WHERE … 
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Types of Objects  

 Four types of objects that can be created 

 Dimensions 

 Base information (Example: Customer) 

 What you query by (Example: Revenue BY Customer …) 

 Details 

 Depend on a dimension (Example: Address) 

 Measures 

 Aggregated calculations (sum, count, min, max, average) 

 Conditions 

 WHERE clauses that are named 

 

3.1 4.x 
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Creating Objects  

 Create objects using any of these techniques 

 Drag a table into the Universe window 

 (creates a class for table, object for each column) 

 Drag a table column into an existing class 

 Automatically create folder and objects 

 Choice when business layer is created 

 NOT a good idea unless you need a quick demo universe 

 Manually create an object 

 Business Layer pane > New > Dimension or Measure or Filter 

 Insert menu > Object or Condition 

 

3.1 4.x 

4.x 

3.1 

3.1 

4.x 

3.1 
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The Object Editor  

 Create the SQL expression using the SELECT pane 

 DO NOT add anything in the WHERE pane 

 For experienced developers 

 Use condition objects instead (just for WHERE clauses) 

 DO ADD descriptions for each object 

 At a minimum: Definition and example 

 The editors look a little different in each version 

 Major concepts are still the same 

 We’ll focus on the SELECT expression and List of Values 

3.1 4.x 
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The Object Editor, cont’d  4.x 
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The Object Editor, cont’d  3.1 
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List of Values  

 Gives the users a “cheat sheet” of object values  

 Used to complete query conditions 

 Steps to create this list: 

 Business Layer > Parameters and List of Values  
List of values based on business layer objects 

 Object Properties          > Properties > Edit 

3.1 4.x 

4.x 

3.1 

In BI 4.x, list of values can 
also be created from a 
static list or custom SQL 
statements as part of the 
Data Foundation layer 
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List of Values, cont’d  

 The List of Values editor looks just like a Web query 

3.1 4.x 

The List of Values query can 
have more than one object, as 
long as the leftmost object 
represents the final value for 
the list, 
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Demonstration 3.1 4.x 
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A Word On Testing  

 Universe development runs in cycles 

 Add a few tables 

 Connect them with joins and resolve any problems 

 Create a few classes and objects 

 TEST using sample queries 

 Query editors are part of Universe Designer, IDT 

 Could also use Web Intelligence if the universe has been published 

 Repeat the process until universe is complete 

3.1 4.x 
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Integrity Checking  

 A sanity check to make sure there are no universe problems 

 Not always 100% accurate 

 BUT … still very much worth the time to use 

 Use the Check Integrity button 

3.1 4.x 

4.x 3.1 
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Publishing  

 Right-click on any business layer 

 Publish > To a Repository… 

4.x 
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Exporting  

 The way to publish universes in XI 3.1 

 File > Export 

3.1 

Domain here represents the 
folder that universe will be 
exported to. More than one 
universe can be exported at 
the same time. 
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Demonstration 3.1 4.x 
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 Creating universes is easy once you know how 

 This presentation showed the basics 

 Download the examples to practice at home 

 Are there more detailed topics? 

 Of course! 

 But this was geared for “Mere Mortals”  

 More advanced topics in future presentations 

Key Learnings 
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Questions? 

Alan Mayer 
Session 0610 
Universe Building for Mere Mortals 
 
alan.mayer@solidgrounded.com 
214-295-6250 (office) 
214-755-5771 (mobile) 
214-206-9003 (fax) 

mailto:alan.mayer@solidegounded.com
mailto:alan.mayer@solidegounded.com


Thank you for participating. 
 

Please provide feedback on this session by 
completing a short survey via the event 

mobile application. 
 

SESSION CODE:  0610 
 
 

Learn more year-round at www.asug.com 


